OVERDRIVE II

Announce (tech) demos or games releases

Moderator: Mask of Destiny

Eke
Very interested
Posts: 821
Joined: Wed Feb 28, 2007 2:57 pm
Contact:

Re: OVERDRIVE II

Post by Eke » Sun Apr 16, 2017 7:13 pm

:shock:

I can't even imagine how this was coded (and debugged), this was surely crazy head scratching and endless experimenting to achieve this. If, as i guess, it relies on very precisely timed VDP writes (FIFO and registers) interleaved with the rendering processing, this is going to be a nightmare to emulate this correctly... Some color effects also are just astonishing, as if there were some analog video effects going on (controlled through new undocumented VDP register bits?). I can't wait for the technical details, especially if it involves new undocumented stuff and hardware variations between console revisions.

@Ralakimus: the version of Genesis Plus GX used in Bizhawk is quite outdated I think, newer versions enable SSF2 bankswitching by default for unknown ROMs so that demo should work (well, at least run) without modifications in the Wii version or with Retroarch for example.

Oerg866
Very interested
Posts: 209
Joined: Sat Apr 19, 2008 10:58 am
Location: Frankfurt, Germany
Contact:

Re: OVERDRIVE II

Post by Oerg866 » Sun Apr 16, 2017 10:17 pm

If you can run the demo on real hardware somehow, we'd appreciate if you could help us with our research by posting the following details:

Model number and revision (e.g. MD1 VA4)
Serial number of the console
Picture of the VDP / ASIC (if possible)
Brief description of glitches experienced (if any)

Thanks in advance!

mikejmoffitt
Very interested
Posts: 86
Joined: Fri Sep 25, 2015 4:16 pm

Re: OVERDRIVE II

Post by mikejmoffitt » Mon Apr 17, 2017 6:08 am

Model: MD1 VA2 JP
Serial: 89N51082
No pic of VDP/ASIC, but it's nothing out of the ordinary.
Glitches experienced: With VDP Debug register blending stuff enabled, sprites showed blank or glitchy columns every 8 pixels; looks like a driving conflict or open bus behavior. Matches what I've seen with prior research into the register.

Morden
Interested
Posts: 33
Joined: Wed Aug 31, 2011 11:30 am

Re: OVERDRIVE II

Post by Morden » Mon Apr 17, 2017 10:04 am

Ok, so I dug up my Neo Myth MD cartridge, and while the first Overdrive runs without any issues, Overdrive 2 gives me the unsupported bank switching message. I can, however, run SSF2 by itself without issues. This would suggest the bank switching is emulated, but maybe not in the way Overdrive 2 expects? Could you share a build of the ROM with the mapper check disabled?

Oerg866
Very interested
Posts: 209
Joined: Sat Apr 19, 2008 10:58 am
Location: Frankfurt, Germany
Contact:

Re: OVERDRIVE II

Post by Oerg866 » Mon Apr 17, 2017 7:37 pm

Morden wrote:Ok, so I dug up my Neo Myth MD cartridge, and while the first Overdrive runs without any issues, Overdrive 2 gives me the unsupported bank switching message. I can, however, run SSF2 by itself without issues. This would suggest the bank switching is emulated, but maybe not in the way Overdrive 2 expects? Could you share a build of the ROM with the mapper check disabled?
Hello,

the mapper check only verifies that it can access the entirety of the ROM. If we were to disable the mapper check, it would crash. :/

Please contact me via PM because we might have a few test ROMs you could run to check if we can fix NeoMYTH support in a different way.

notaz
Very interested
Posts: 176
Joined: Mon Feb 04, 2008 11:58 pm
Location: Lithuania

Re: OVERDRIVE II

Post by notaz » Tue Apr 18, 2017 10:40 pm

http://notaz.gp2x.de/img/hw/megadrive_model1.jpg
http://notaz.gp2x.de/img/hw/megadrive_m ... e_back.jpg
(with MED + both addons attached)

Just like the demo itself warns, some plane glitches on "where is she" and few other scenes.
Other than that, really enjoyable demo, much appreciated! Thanks for getting me to unbox my gear, might try to revive some old project or something.

kode54
Newbie
Posts: 2
Joined: Sat Oct 25, 2008 11:19 pm

Re: OVERDRIVE II

Post by kode54 » Wed Apr 19, 2017 1:32 am

Too bad Exodus never got around to SSF2 support before it died in the water, or else we'd know if it had a snowball's chance in heck of supporting this fine demo.

Boyfinn
Interested
Posts: 38
Joined: Sat Aug 08, 2015 12:12 pm
Location: Lapland, Finland

Re: OVERDRIVE II

Post by Boyfinn » Mon Apr 24, 2017 2:24 pm

Genesis does what nintendont :D :D :D

Jpg3D
Interested
Posts: 20
Joined: Mon Mar 03, 2014 9:19 pm

Re: OVERDRIVE II

Post by Jpg3D » Thu Apr 27, 2017 3:43 pm

Image

This is the only error i get on my megadrive. Sometimes the video looses syncs so my screen turns off and i cant see any. Sometimes the demo looks fine. But that robots seems to be corrupt on every test

Tested on
PAL-B(VE)
nº 1061-07
serial number b10003149

vdp is:
315-5313
3101-9112-EAIE

I hope you can find usefull this information.
Last edited by Jpg3D on Thu Apr 27, 2017 6:10 pm, edited 2 times in total.

User avatar
TmEE co.(TM)
Very interested
Posts: 2293
Joined: Tue Dec 05, 2006 1:37 pm
Location: Estonia, Rapla City
Contact:

Re: OVERDRIVE II

Post by TmEE co.(TM) » Thu Apr 27, 2017 3:45 pm

315-5433 in the IO+bus management chip. VDP is the other chip (315-5313 / 5313A / 5313A-01)
Mida sa loed ? Nagunii aru ei saa ;)
http://www.tmeeco.eu
Files of all broken links and images of mine are found here : http://www.tmeeco.eu/FileDen

Jpg3D
Interested
Posts: 20
Joined: Mon Mar 03, 2014 9:19 pm

Re: OVERDRIVE II

Post by Jpg3D » Thu Apr 27, 2017 5:51 pm

315-5433 in the IO+bus management chip. VDP is the other chip (315-5313 / 5313A / 5313A-01)
You'r right. Post Fixed.

User avatar
astrofra
Interested
Posts: 26
Joined: Sun Dec 14, 2014 8:50 am
Location: Orleans | France
Contact:

Re: OVERDRIVE II

Post by astrofra » Sun Apr 30, 2017 7:48 am

Thanks, Titan, for such an inspirational work with an incredible amount of R&D.
640 polygons are enough for everyone.

Trihook
Newbie
Posts: 5
Joined: Sun May 01, 2016 7:22 am

Re: OVERDRIVE II

Post by Trihook » Sat May 06, 2017 1:11 pm

I just watched it, this is pure awesomeness on wheels! Amazing! =D =D =D

Morden
Interested
Posts: 33
Joined: Wed Aug 31, 2011 11:30 am

Re: OVERDRIVE II

Post by Morden » Sun May 07, 2017 10:43 am

Ok, so I have finally been able to test Overdrive 2 on real hardware. Both consoles used were MegaDrive II MK-1631-50. Strangely enough, one had only the slightest glitching on the robot, the same scene Jpg3D had issues with, and the other ran perfectly as far as graphics, BUT ... it lacked the PCM soundtrack. The initial Pong, static and ship launch sound effects are there, but there's no music.

This might be an issue with the console, though. For the longest time it has been behaving strangely. It's usually shaky image. When I was using it more regularly, I had to power it on and off rapidly a couple of times to jolt it into submission. Sound in games works fine, though, but games don't really use PCM soundtracks the way Overdrive 2 does.

I haven't opened them up to give you the specifics on the parts, but I'll do it when I have some time on my hands. Also, just for the heck of it, I tried the demo on a Japanese console, just to see that arcade screen telling me I need PAL 50Hz. Nice touch. Better than the text only message about the SSF2 mapper!

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests