show a 256 colors picture in MD

For anything related to VDP (plane, color, sprite, tiles)

Moderators: BigEvilCorporation, Mask of Destiny

Oerg866
Very interested
Posts: 211
Joined: Sat Apr 19, 2008 10:58 am
Location: Frankfurt, Germany
Contact:

Post by Oerg866 » Tue Jul 03, 2012 2:56 pm

Chilly Willy wrote:Yeah, emulators aren't designed to handle this... neither Gens/GS nor Fusion handle it correctly. It works great on my CDX - very stable. Any source on this? I'd like to do some experimenting with it. :D
as soon as I can be bothered to boot up my old barebone again :D

(I wrote the code on a tiny athlon XP box :X)

Chilly Willy
Very interested
Posts: 2736
Joined: Fri Aug 17, 2007 9:33 pm

Post by Chilly Willy » Tue Jul 03, 2012 7:05 pm

Oerg866 wrote:
Chilly Willy wrote:Yeah, emulators aren't designed to handle this... neither Gens/GS nor Fusion handle it correctly. It works great on my CDX - very stable. Any source on this? I'd like to do some experimenting with it. :D
as soon as I can be bothered to boot up my old barebone again :D

(I wrote the code on a tiny athlon XP box :X)
Cool - thanks! No rush... I got PLENTY of other things to keep me busy. :lol:

Oerg866
Very interested
Posts: 211
Joined: Sat Apr 19, 2008 10:58 am
Location: Frankfurt, Germany
Contact:

Post by Oerg866 » Fri Jul 20, 2012 11:58 pm

Here it is... Cleaned it up a bit... http://oerg866.mdscene.net/BITMAP.zip

Chilly Willy
Very interested
Posts: 2736
Joined: Fri Aug 17, 2007 9:33 pm

Post by Chilly Willy » Sat Jul 21, 2012 12:55 am

Oerg866 wrote:Here it is... Cleaned it up a bit... http://oerg866.mdscene.net/BITMAP.zip
Thanks! Hmm - I'll have to dig into the VDP commands. Definitely an interesting program to study.
8)

bobthebuilder
Interested
Posts: 22
Joined: Thu Jun 19, 2008 4:36 am

Post by bobthebuilder » Mon Oct 29, 2012 4:45 pm

Darn, I can't get Oerg866's FantomBitmap to run on my Model 1 Genesis with the Mega Everdrive :oops: . Is there something I can do to remedy this problem?
Stef wrote:Just check the 960 colors demo on this page :
viewtopic.php?t=53
This also seems to not work well for me :(. The palette is unstable, it rapidly scrolls vertically on the screen.

Chilly Willy
Very interested
Posts: 2736
Joined: Fri Aug 17, 2007 9:33 pm

Post by Chilly Willy » Mon Oct 29, 2012 6:48 pm

Sounds like it might be PAL and you're on NTSC. While you can set the extended height mode (240 lines instead of 224) on an NTSC console, it causes the display to spaz out because NTSC only allows for 239 active lines, so the extra line interferes with the vertical blank signal.

Muzzy
Interested
Posts: 17
Joined: Mon Jun 19, 2017 5:06 pm

Re: show a 256 colors picture in MD

Post by Muzzy » Sun Apr 21, 2019 2:03 pm

Does anyone still have this BITMAP.zip file with source code by Oerg866 ?

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests