Problem building tools

Hosted forum for UMDK related questions

Moderators: BigEvilCorporation, prophet36

Post Reply
Montserrat
Very interested
Posts: 114
Joined: Fri Sep 18, 2015 2:56 pm

Problem building tools

Post by Montserrat » Mon Apr 15, 2019 11:23 am

Hi there, its been a while :D

I was installing the tools folowing the wiki commands, but seems somethings wrong with the files...

Code: Select all

cd ${HOME}
mkdir 20151220
cd 20151220
wget -qO- http://tiny.cc/msbil | tar zxf -
cd makestuff
scripts/msget.sh makestuff/hdlmake/20151220
cd hdlmake/apps
mkdir makestuff
cd makestuff
../../../scripts/msget.sh makestuff/umdkv2
cd umdkv2/scripts
./build-sgdk.sh  <----------------------------------------------------------------- HERE
cd ../m68k/menu
./dbg.sh
And this is the output i get in terminal, there is some spanish there btw:

Code: Select all

root@sega-VirtualBox:/home/sega/20151220/makestuff/hdlmake/apps/makestuff/umdkv2/scripts# ./build-sgdk.sh
Fetching SGDK v095...
xz: (stdin): Formato de archivo no reconocido
tar: Child returned status 1
tar: Error is not recoverable: exiting now
Patching...
./build-sgdk.sh: 13: cd: can't cd to sgdk095
./build-sgdk.sh: 14: ./build-sgdk.sh: cannot create src/libres.s: Directory nonexistent
./build-sgdk.sh: 251: ./build-sgdk.sh: cannot create src/Makefile: Directory nonexistent
rm: no se puede borrar 'src/z80_ctrl.c': No existe el archivo o el directorio
patching file src/sys.c
Hunk #1 FAILED at 582.
patch: **** Can't reopen file src/sys.c : No such file or directory
Building...
make: se entra en el directorio '/home/sega/20151220/makestuff/hdlmake/apps/makestuff/umdkv2/m68k/src'
make: *** No se especificó ningún objetivo y no se encontró ningún makefile.  Alto.
make: se sale del directorio '/home/sega/20151220/makestuff/hdlmake/apps/makestuff/umdkv2/m68k/src'
Seems like it does not recognize files, or there are missing ones, or may be corrupted...i've downloaded them again with no results. Most folders on the dropbox are empty, Is there something missing?

Montserrat
Very interested
Posts: 114
Joined: Fri Sep 18, 2015 2:56 pm

Re: Problem building tools

Post by Montserrat » Mon Apr 15, 2019 6:40 pm

First post was about building the tools in linux, and this one is for the windows ones, i cannot build them too :S here there is the build.log:

https://pastebin.com/ZZk1puVQ

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests