XGM sfx channels sometimes not working

SGDK only sub forum

Moderator: Stef

Post Reply
cero
Very interested
Posts: 234
Joined: Mon Nov 30, 2015 1:55 pm

XGM sfx channels sometimes not working

Post by cero » Tue Sep 20, 2016 12:36 pm

Sometimes the XGM sfx channel 0 does not work. I assume it's because that channel can be used by the playing XGM music?

I couldn't find docs on what channels the music is allowed to take, and at what priority does it take them.

User avatar
Stef
Very interested
Posts: 2801
Joined: Thu Nov 30, 2006 9:46 pm
Location: France - Sevres
Contact:

Re: XGM sfx channels sometimes not working

Post by Stef » Tue Sep 20, 2016 1:25 pm

Ah yeah it's not specified in the documentation because logically you could potentially have 4 PCM channel music and just play with priorities. But indeed when you are converting VGM music (which is the only way to have XGM music for now), only 1 PCM channel is used for music and it's affected to channel #0. I don't remember what is the priority given in that case but i would suggest you to preferably dedicate channel #1,#2,#3 to SFX and keep #0 for music PCM :)

cero
Very interested
Posts: 234
Joined: Mon Nov 30, 2015 1:55 pm

Re: XGM sfx channels sometimes not working

Post by cero » Tue Sep 20, 2016 6:15 pm

Please document this, both in the sound.h header and the xgmtool docs.

User avatar
Stef
Very interested
Posts: 2801
Joined: Thu Nov 30, 2006 9:46 pm
Location: France - Sevres
Contact:

Re: XGM sfx channels sometimes not working

Post by Stef » Tue Sep 20, 2016 8:28 pm

Added a comment in the XGM_playPCM(..) method on github.
I plan to release soon a new version :)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest