Unable to open application (0xc000007b) error

Official support forum for the Exodus Emulation Platform

Moderator: Nemesis

Post Reply
Posts: 1
Joined: Mon Sep 28, 2015 4:45 am

Unable to open application (0xc000007b) error

Post by drewmaster » Mon Sep 28, 2015 5:02 am

I installed the Visual C++ 2013 x64 Runtime and I still get this error. No matter what I've tried I see this pop up on the screen...

The application was unable to start correctly (0xc000007b). Click OK to close the application.

I have...

Windows 7 Home Premium Service Pack 1
Intel(R) Pentium(R) CPU G840 2.80GHz
6.00 GB RAM

Very interested
Posts: 773
Joined: Wed Nov 07, 2007 1:09 am
Location: Sydney, Australia

Re: Unable to open application (0xc000007b) error

Post by Nemesis » Mon Sep 28, 2015 10:04 pm

Hmmm. Something on your local machine must be a bit screwy. The only non-windows dll being loaded here is the Visual C++ runtimes, so it's almost certainly that causing the problem.

I'm going to take a stab in the dark here, but would I be correct in assuming you upgraded to Windows 7 from a previous version rather than doing a clean install, and the previous install of Windows was 32-bit, while you now have a 64-bit install? As I said, a bit of a stab in the dark, but it wouldn't surprise me if this was the case. There could have been other scenarios which led to this point though. I'm suspecting you've got some 32-bit dll's stuck in your system32 directory, even though you're on a 64-bit install. These could be masking the correct dll's in your SxS assembly store.

Here's what I'd recommend:
-Go to Add/Remove programs (or Programs and Features or whatever it's now called)
-Uninstall ALL versions of "Microsoft Visual C++ 2013 Redistributable"
-Restart your computer
-Go to your Windows directory, and under the "System" and "SysWOW64" directories, search for "MSVCP120.dll", or "MSVCR120.dll". If you find them there, remove them. If you get errors about them being in use, you're going to have to reboot in safe mode and try there instead.
-Re-install the Microsoft Visual C++ 2013 redistributable, both the x86 and x64 versions this time.

That should get you up and running. If it doesn't, there could be something more serious going on, like a malicious program trying to (incorrectly) substitute another dll in the place of the real one.

Post Reply