Oops! Memory Leak...

Official support forum for the Exodus Emulation Platform

Moderator: Nemesis

Post Reply
Oerg866
Very interested
Posts: 209
Joined: Sat Apr 19, 2008 10:58 am
Location: Frankfurt, Germany
Contact:

Oops! Memory Leak...

Post by Oerg866 » Tue Jun 11, 2013 2:53 pm

Image

User avatar
Nemesis
Very interested
Posts: 670
Joined: Wed Nov 07, 2007 1:09 am
Location: Sydney, Australia

Post by Nemesis » Wed Jun 12, 2013 2:14 am

Ouch! What were you doing at the time? Did the emulator itself stop or hang? Did the memory usage suddenly spike, or did it creep up over time? Had you changed games a lot in the one session? How long did you have it running?

Oerg866
Very interested
Posts: 209
Joined: Sat Apr 19, 2008 10:58 am
Location: Frankfurt, Germany
Contact:

Post by Oerg866 » Tue Jun 18, 2013 11:42 am

Nemesis wrote:Ouch! What were you doing at the time? Did the emulator itself stop or hang? Did the memory usage suddenly spike, or did it creep up over time? Had you changed games a lot in the one session? How long did you have it running?
Hi,

sorry for my late answer.

What I was doing, I was debugging our demo and so I made small code changes and reloaded the rom tons of times. But that's when the usage was normal.

I didn't have a looppoint defined so after a while it wrote random ROM data all over the VDP (which looked really funky ;P), and I had it running in the BG for some hours. Later I was wondernig why my system was suddenly hanging like crazy... and well, there you go.

It happened again today, when I woke up it consumed 13GB of RAM...Weird stuff.

BTW, alk might have already messaged you, we have lots more test ROMS that are inaccurate on Exodus, maybe they can help you in development ;) (Bus timing woes, Z80 using iit affecting everything else, etc)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest