A few bugs

Official support forum for the Exodus Emulation Platform

Moderator: Nemesis

Post Reply
Paul Jensen
Interested
Posts: 32
Joined: Mon Apr 06, 2009 4:17 pm
Location: Hiroshima, Japan

A few bugs

Post by Paul Jensen » Fri May 03, 2013 1:34 am

First of all, Nemesis, fantastic work on Exodus. It’s an excellent first release, and the YM2612 emulator sounds so close to the real thing it's almost scary.

Here are a few bugs that I don't think anybody's mentioned yet:
-- Assault Suits Leynoss (J): The YM2612 and the PSG can get out of sync when changing tunes in the sound test, and stay out of sync until a hard reset.
-- Phantasy Star II (U): Saving to one save slot saves identical data to all the save slots at once.
-- Kid Chameleon (U): On the options screen, the YM2612 wigs out plays a single note really loudly and with the wrong timbre.

User avatar
Nemesis
Very interested
Posts: 670
Joined: Wed Nov 07, 2007 1:09 am
Location: Sydney, Australia

Post by Nemesis » Fri May 03, 2013 3:49 am

Thanks for the bug report! I'm currently setting up a new development machine. Once I'm fully back online, I'll be investigating all the issues that have been reported and working towards a bugfix release to knock as many of them off as possible.

Paul Jensen
Interested
Posts: 32
Joined: Mon Apr 06, 2009 4:17 pm
Location: Hiroshima, Japan

Post by Paul Jensen » Fri May 03, 2013 7:19 am

Cool! Good luck with the bugfixing.

Also, a note to the moderator: I didn't realize I had created a new topic here. Please feel free to merge this thread with the existing thread about bugs.

User avatar
Nemesis
Very interested
Posts: 670
Joined: Wed Nov 07, 2007 1:09 am
Location: Sydney, Australia

Post by Nemesis » Tue May 07, 2013 10:47 am

Phantasy Star II (U): Saving to one save slot saves identical data to all the save slots at once.
I haven't been able to duplicate this problem. If you can reproduce this issue, can you send me the exact full filename of the ROM you're loading, as well as the filename of the savestate that's generated in your savestate folder when you do a save?

Paul Jensen
Interested
Posts: 32
Joined: Mon Apr 06, 2009 4:17 pm
Location: Hiroshima, Japan

Post by Paul Jensen » Wed May 08, 2013 12:48 am

Nemesis wrote:
Phantasy Star II (U): Saving to one save slot saves identical data to all the save slots at once.
I haven't been able to duplicate this problem. If you can reproduce this issue, can you send me the exact full filename of the ROM you're loading, as well as the filename of the savestate that's generated in your savestate folder when you do a save?
I was able to reproduce the bug with three versions of Phantasy Star II:

"Phantasy Star II (J) [!].gen"
"Phantasy Star II (UE) (REV01).gen"
"Phantasy Star II (UE) (REV02) [!].gen"

All thee ROMs have been verified/named with GoodGen 3.00. The save files (in the PersistentState subfolder) are named as follows:

"Phantasy Star II (J) [!].gen.zip"
"Phantasy Star II (UE) (REV01).gen.zip"
"Phantasy Star II (UE) (REV02) [!].gen.zip"

Each of the .zip files contains two files, for example:

"Phantasy Star II (J) [!].gen.SRAM.bin"
and "save.xml"

Also, there's more to this story. :(

I tested some other ROMs that use SRAM saves, and none of them worked properly. The files are showing up in the PersistentState subfolder as (I assume) they should, and the file names match up with the ROM file names, but the games themselves report the save data as either corrupt or nonexistent when I attempt to load data from SRAM.

Also, it looks like the YM2612/PSG desynchronization problem can happen with any game. I noticed the PSG lagging by about 1/3 of a second while I was testing the SRAM thing.

If it helps, here are my basic system specs:

Intel Core i7 2600K (not overclocked)
6GB RAM (don't know the brand)
eVGA nVidia GeForce 560 Ti 1GB (factory overclocked)
Creative Sound Blaster Z
Windows 8 Pro (64-bit)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest