Mega Drive VDP Debug Settings Window

Official support forum for the Exodus Emulation Platform

Moderator: Nemesis

Post Reply
panzeroceania
Interested
Posts: 27
Joined: Sat Sep 12, 2009 4:02 am
Location: Salem, OR

Mega Drive VDP Debug Settings Window

Post by panzeroceania » Tue Apr 30, 2013 4:52 pm

I know in a past version of Exodus, you could select

Debug>VDP>Settings

it would bring up a settings window that would allow you to enable VRAM Sync, CRAM Sync, VSRAM Sync, as well as enable the emulation of two VDP Bugs

Window distortion bug
Flicker on CRAM write

I was wondering if these are enabled by default in version 1.0, and if not, if there is any way to enable them.

Here is the older build that I was referring to:

http://nemesis.hacking-cult.org/Exodus/ ... -02-04.rar

User avatar
Nemesis
Very interested
Posts: 670
Joined: Wed Nov 07, 2007 1:09 am
Location: Sydney, Australia

Post by Nemesis » Tue Apr 30, 2013 9:59 pm

Those settings are now always on. The window distortion bug was previously specifically implemented as an extra step. After some hardware testing and thought, I managed to derive a more accurate implementation of the window layer emulation where the distortion bug is a natural side-effect of the way it's implemented. As a result, it's no longer optional, it's simply the way it behaves. The VRAM/CRAM/VSRAM sync and CRAM flicker settings were previously optional because there was a significant performance hit turning them on. I've now got a much better implementation where there's no performance hit from keeping perfect sync with these buffers, and emulating the CRAM flicker, unless there really are changes being made that require lots of updates, in which case, turning synchronization off would definitely result in a loss of accuracy, so these settings are no longer optional.

panzeroceania
Interested
Posts: 27
Joined: Sat Sep 12, 2009 4:02 am
Location: Salem, OR

Post by panzeroceania » Wed May 01, 2013 4:49 pm

Thanks, that's exactly what I was hoping you would say. The first thing I used to do was turn those settings on, so I'm glad to hear that it's all on and being emulated by default.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest