Regen 0.972 and 0.972D

AamirM's Regen forum

Moderator: AamirM

User avatar
Shadow
Very interested
Posts: 257
Joined: Wed Sep 16, 2009 7:13 am
Location: Russian Federation
Contact:

Post by Shadow » Mon Oct 26, 2009 3:26 pm

Now i just rewrite issues which i have:

Game Gear/SMS:

If you open a Genesis game and then a Game Gear game, the Game Gear won't start until 4 or 7 seconds (sometimes will take longer)
pop\crackle at Sega logo
Scanlines + stretch, screen moved to right
Surprisingly! i enable color borders for SMS\GG and get this bug too!
If use this setups, screen in GG go to diagonal down!
Stretch + Output Aspect 4:3, and screen very wide like a 16:9!
Borders may cut image! on 50%
Tails Adventure crash after glitch showed sega logo!
Using scaler Hq4x plugin cause to crash Game Gear/SMS!

Sega Mega Drive:

Sram issues with games for example: Holyfield Evander, Micro machines 2/military, Phantasy Star 4, Beyound Oasis. etc
Regen create Sram for all games include which no support it, i'm in shock! i open Sram folder and see what all games here! :-O
Click on empty space in cheat file list, cause to crash emu.
I have issues setting up my controller with Regen too. It locks up when trying to associate buttons
FPS always show: 59.63 ~ 60.78 but picture scroll not smooth sometimes, for example: Sonic 3D Blast.

Another bugs anoying me rarely, and i always forgot something ;-)

User avatar
King Of Chaos
Very interested
Posts: 268
Joined: Fri Feb 29, 2008 8:12 pm
Location: United States

Post by King Of Chaos » Mon Oct 26, 2009 6:38 pm

Shadow wrote:FPS always show: 59.63 ~ 60.78 but picture scroll not smooth sometimes, for example: Sonic 3D Blast.
Just wondering, are you using Vista?

AamirM
Very interested
Posts: 469
Joined: Mon Feb 18, 2008 8:23 am
Contact:

Post by AamirM » Tue Oct 27, 2009 7:36 am

Thanks everyone for testing this. I'll check out all the reported bug. They don't seem to major except for that SRAM problems.
Regen create Sram for all games include which no support it, i'm in shock! i open Sram folder and see what all games here! :-O
Yes thats expected. Regen creates SRAM for games smaller than 2MB. But they are unused. So don't worry about it :) .
FPS always show: 59.63 ~ 60.78 but picture scroll not smooth sometimes, for example: Sonic 3D Blast.
If you are using Vista, that will happen. I will be fixing this soon.

User avatar
Shadow
Very interested
Posts: 257
Joined: Wed Sep 16, 2009 7:13 am
Location: Russian Federation
Contact:

Post by Shadow » Wed Oct 28, 2009 11:34 am

Use my setups: Boost PSG Noise and Volume levels -> PSG -> 1.40 and
(note: I use speakers on 3-5 Watt)

(deleted mess)
Last edited by Shadow on Mon Feb 15, 2010 11:45 pm, edited 1 time in total.

User avatar
Shadow
Very interested
Posts: 257
Joined: Wed Sep 16, 2009 7:13 am
Location: Russian Federation
Contact:

Post by Shadow » Wed Oct 28, 2009 3:55 pm

Thanks for amazing emulator Regen i happy.

Thanks to King of Chaos, AamirM, xZABUZAx, and others :)
Last edited by Shadow on Mon Feb 15, 2010 11:47 pm, edited 1 time in total.

User avatar
Shadow
Very interested
Posts: 257
Joined: Wed Sep 16, 2009 7:13 am
Location: Russian Federation
Contact:

Post by Shadow » Wed Oct 28, 2009 4:59 pm

I found small bug in interface!
in Volume Levels option, i change values of volume and click Cancel but changed values saved!

User avatar
Shadow
Very interested
Posts: 257
Joined: Wed Sep 16, 2009 7:13 am
Location: Russian Federation
Contact:

Post by Shadow » Fri Oct 30, 2009 11:25 pm

Mega Drive games no crash, i test it long time, i tested my last Mega Drive games and all fine.

And when next version will be released? :-)
Hmm.. in this forum so silent! :wink:

User avatar
King Of Chaos
Very interested
Posts: 268
Joined: Fri Feb 29, 2008 8:12 pm
Location: United States

Post by King Of Chaos » Sat Oct 31, 2009 3:20 am

Yeah, I think all the crashes are close to being non-existent. :P

AamirM
Very interested
Posts: 469
Joined: Mon Feb 18, 2008 8:23 am
Contact:

Post by AamirM » Sat Oct 31, 2009 8:03 am

Shadow wrote:Mega Drive games no crash, i test it long time, i tested my last Mega Drive games and all fine.

And when next version will be released? :-)
Hmm.. in this forum so silent! :wink:
I've been busy coding some other stuff so thats why I haven't been much active for the past week or so. Also, the next version will probably be released in six months or so (unless there is a very critical bug found ;)).

User avatar
Shadow
Very interested
Posts: 257
Joined: Wed Sep 16, 2009 7:13 am
Location: Russian Federation
Contact:

Post by Shadow » Sat Oct 31, 2009 7:45 pm

AamirM

Really serious bugs, well i wait, and when next version will be released i try to check all games once again :)

Six months? yeah very long time to wait! but i don't give up :)
Last edited by Shadow on Mon Feb 15, 2010 11:50 pm, edited 1 time in total.

eighty5cacao
Interested
Posts: 15
Joined: Thu Sep 25, 2008 9:11 pm

Post by eighty5cacao » Mon Nov 02, 2009 1:23 am

Sorry that I've been busy again, and sorry for reporting bugs that you've been unable to reproduce (there's a chance that Comodo Internet Security and/or ThreatFire has been subtly conflicting with some part of Regen, but I don't have a good chance to uninstall either of those just for testing).

Anyway, thank you for all the good work. Everything I mention below has been tested on 0.97D, 0.971D, and 0.972D.

Here are a couple of bugs I'd like to point out:
1. Attempting to close the "YM2612 Channel Select" or "VDP Layer Select" debugging windows by clicking the X in the upper right-hand corner does nothing. This has existed since 0.95D but I didn't get around to reporting it.
2. In the game High Seas Havoc (U) [!] the first couple of seconds of the intro music play too fast. In the corresponding PAL version Capt'n Havoc (E) [!] the intro music pauses for several seconds after the first note before resuming normally. These issues only seem to happen on the first loop of the attract mode. This has existed since 0.96 but I didn't get a chance to report it.

A couple of clarifications on bugs I previously mentioned:
Regarding Forgotten Worlds going to game over screen after intro: I forgot to mention that the attract mode runs fine. Could this have something to do with inaccurate WRAM initialization?
Regarding the unlicensed games Iraq War 2003 (Unl) and Commandos (R) not having sound: Upon examining with the Z80 debugger, it looks like the Z80 is getting stuck on a HALT opcode and not receiving the interrupt it needs to continue(?)

Finally, a couple of minor feature requests:
1. A numerical adjustment for the "Boost PSG Noise" setting - the volume levels window could have sliders for FM, PSG Noise, and PSG Overall (What amplification factor does the setting currently use?)
2. Change the default setting for Autofix Checksum to disabled, now that the unlicensed protection chips and some licensed games require it to be disabled; this should make things more noob-friendly

OT: Just out of curiosity, is NBA Jam Tournament Edition the game that Chris Kirby is referring to in the comments here?
Last edited by eighty5cacao on Mon Nov 02, 2009 2:57 am, edited 1 time in total.

User avatar
Shadow
Very interested
Posts: 257
Joined: Wed Sep 16, 2009 7:13 am
Location: Russian Federation
Contact:

Post by Shadow » Mon Nov 02, 2009 1:37 am

eighty5cacao

Yes "High Seas Havoc" have this sound problem, unfortunately i forgot report it again and again, just i have reasons! in last week i tested huge collection of games and completely forgot about some games.

Bad news, AamirM found serious bug in Regen and it may take long time to fix, i hope he can do it :D

Thanks you really help me! i play sometimes "High Seas Havoc" this is cool game more close to Sonic the hedgehog ;-)

User avatar
King Of Chaos
Very interested
Posts: 268
Joined: Fri Feb 29, 2008 8:12 pm
Location: United States

Post by King Of Chaos » Mon Nov 02, 2009 4:06 pm

Shadow wrote:Bad news, AamirM found serious bug in Regen and it may take long time to fix
Please elaborate? What kind of serious bug is it?

User avatar
Shadow
Very interested
Posts: 257
Joined: Wed Sep 16, 2009 7:13 am
Location: Russian Federation
Contact:

Post by Shadow » Mon Nov 02, 2009 7:10 pm

King of Chaos

I don't known what serious bugs, ask AamirM he know it ;-)
But i try to understand it, maybe save system have bugs or core?
Alright i give up! AamirM what serious bug you found! :-)
So interest information i must know it.

User avatar
King Of Chaos
Very interested
Posts: 268
Joined: Fri Feb 29, 2008 8:12 pm
Location: United States

Post by King Of Chaos » Wed Nov 04, 2009 1:28 am

Aamir, I'm wondering if you can create some kind of quick cheat converter for the cheat files (the PATs) found inside this archive? If so, I can convert the entire Game Genie code database, edit all the multi-line codes, and release a major cheat pack update. :P

If not, do you still have the Kega to Regen cheat converter you made a few years ago?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest