Search found 44 matches

by amushrow
Sun Apr 09, 2017 10:36 am
Forum: UMDK
Topic: MD hangs after playing any PCM file
Replies: 69
Views: 16540

Re: MD hangs after playing any PCM file

Ah probe, 1X - 6Mhz, 10x - 100Mhz so the signal was being heavily attenuated. I've never had a scope before so you'll have to forgive me. However I have found some more useful information. The UMDK's bridge board triggers signals at ~2v (for me anyway), probing /OE (on both the MD side and the FPGA ...
by amushrow
Fri Apr 07, 2017 9:36 pm
Forum: UMDK
Topic: MD hangs after playing any PCM file
Replies: 69
Views: 16540

Re: MD hangs after playing any PCM file

It's your cheap (relatively) chinese jobby - Hantek DSO5102P, but it comes under a few different names. For sure the probes won't be the best.
by amushrow
Fri Apr 07, 2017 6:01 pm
Forum: UMDK
Topic: MD hangs after playing any PCM file
Replies: 69
Views: 16540

Re: MD hangs after playing any PCM file

What Mega Drive are those voltages from?
I've just checked on a Mega Drive II and I'm seeing EDClk go between 0-4.5V, is it possible that on some Mega Drives the signal is too weak?
by amushrow
Wed Apr 05, 2017 6:28 pm
Forum: UMDK
Topic: MD hangs after playing any PCM file
Replies: 69
Views: 16540

Re: MD hangs after playing any PCM file

So here's some shots of EDClk, triggered as it switched to 10.6Mhz On a regular cart: http://www.skgenius.co.uk/FileDump/MD_0.png On UMDK: http://www.skgenius.co.uk/FileDump/UMDK_0.png And if you look in this pic you can see clearly that there's a repeating pattern running through, which repeats at ...
by amushrow
Tue Apr 04, 2017 10:44 pm
Forum: UMDK
Topic: MD hangs after playing any PCM file
Replies: 69
Views: 16540

Re: MD hangs after playing any PCM file

So for today's pokes and prods I was using one of my Mega Drives which is modded with phono jacks for audio + composite so it doesn't need any special cables (the composite is pinched from the DIN so there's nothing fancy there, actually the audio jacks are currently disconnected so it makes the who...
by amushrow
Mon Apr 03, 2017 6:58 pm
Forum: UMDK
Topic: MD hangs after playing any PCM file
Replies: 69
Views: 16540

Re: MD hangs after playing any PCM file

Just found an interesting artefact before looking into this more betterer. If i switch the console from NTSC to PAL while it's running, then it doesn't crash when playing the SFX. Or at least MJ's Moonwalker doesn't, although the game runs slow if you switch it when running.
by amushrow
Mon Apr 03, 2017 4:28 pm
Forum: UMDK
Topic: MD hangs after playing any PCM file
Replies: 69
Views: 16540

Re: MD hangs after playing any PCM file

Yeah, I've put this together myself.
Doing a trace is my plan for this evening, along with checking the expected behavior in an emulator
by amushrow
Sun Apr 02, 2017 1:59 pm
Forum: UMDK
Topic: MD hangs after playing any PCM file
Replies: 69
Views: 16540

Re: MD hangs after playing any PCM file

Tried on my other MD1 (same board, but with a different colour silkscreen) same issue
by amushrow
Sun Apr 02, 2017 12:48 pm
Forum: UMDK
Topic: MD hangs after playing any PCM file
Replies: 69
Views: 16540

Re: MD hangs after playing any PCM file

Silkscreen says IC BD M5 PAL, checking out http://segaretro.org/Mega_Drive_PCB_revisions it looks like a VA6
by amushrow
Sun Apr 02, 2017 11:55 am
Forum: UMDK
Topic: MD hangs after playing any PCM file
Replies: 69
Views: 16540

MD hangs after playing any PCM file

When playing a rom through the UMDK it all works fine until some pcm type sound file is played and then the game hangs. So if we take the common example of Sonic 1, as soon as the game starts you get to hear the wonderful "SEGAAA" sound clip, after which the game crashes (Illegal instruction $00071F...
by amushrow
Wed Mar 29, 2017 8:31 pm
Forum: UMDK
Topic: USB device not recognised (CY7C68014A woes)
Replies: 5
Views: 1564

Re: USB device not recognised (CY7C68014A woes)

So I got an oscilloscope (always nice to have an excuse to buy some new gear), the crystal is oscillating fine (with the 22pf caps) It seems that the reset pin is outputting 3.3v (which for sure is not supposed to happen) I disconnected the resistor at R2 to verify, and sure enough it's getting some...
by amushrow
Sun Mar 19, 2017 11:25 pm
Forum: UMDK
Topic: USB device not recognised (CY7C68014A woes)
Replies: 5
Views: 1564

Re: USB device not recognised (CY7C68014A woes)

They've already been replaced.
Increasing the capacitance gets the crystal going but it's unstable. I'll have to pick up some different values and see what it needs.
The boards are identical though, I can only guess that the working board is just scraping by.
by amushrow
Sun Mar 19, 2017 10:45 pm
Forum: UMDK
Topic: USB device not recognised (CY7C68014A woes)
Replies: 5
Views: 1564

Re: USB device not recognised (CY7C68014A woes)

All voltages match on the boards, resistors are correct. Quite by chance I've managed to replicate the behaviour on the working board. If I measure the voltage at the crystals leg and hold the probes long enough (5-10 seconds), that stops the crystal until the device is reset. The leg now shows as 3...
by amushrow
Sun Mar 19, 2017 6:43 pm
Forum: UMDK
Topic: USB device not recognised (CY7C68014A woes)
Replies: 5
Views: 1564

USB device not recognised (CY7C68014A woes)

I've been putting together a couple of boards but one of them is giving me jip. One of them enumerates properly and the usb device shows up, the other does not. There are no dry joints (that I could find, obviously). There are no shorts between any of the pins on anything anywhere, i've looked with ...