Search found 237 matches

by powerofrecall
Sun Apr 24, 2016 4:15 pm
Forum: Megadrive/Genesis
Topic: Alright dudes, I need your help! (soft-reset bug)
Replies: 37
Views: 6488

Re: Alright dudes, I need your help! (soft-reset bug)

I am assuming that the busreq is maybe happening twice somehow and locking it but I am having trouble understanding how this might be happening.
by powerofrecall
Sun Apr 24, 2016 4:11 pm
Forum: Megadrive/Genesis
Topic: Alright dudes, I need your help! (soft-reset bug)
Replies: 37
Views: 6488

Alright dudes, I need your help! (soft-reset bug)

I got a problem with a thing you guys. It runs fine up until you soft-reset it. This is a problem for me because my only flash cart is a megacart--which my ROM doesn't work on at all, so I'm assuming a Megacart does a soft-reset when a ROM is selected. So I can't run on real hardware because I get n...
by powerofrecall
Sun Nov 01, 2015 3:33 pm
Forum: Blabla
Topic: GEMS YouTube video
Replies: 91
Views: 23540

Re: GEMS YouTube video

I haven't posted in this thread forever but I'd just like everyone to know I have settled on using GEMS in my game (copyright issues be damned!) and I will try to post a video of how this works eventually for anyone who wants to see without diving into it.
by powerofrecall
Sun Nov 01, 2015 3:30 pm
Forum: Tools
Topic: Sprite character utility
Replies: 5
Views: 2051

Re: Sprite character utility

mdtiler does it (when you use the command "layout sprite") https://github.com/sikthehedgehog/mdtools/tree/master/mdtiler it favors giving full control and using makefiles over an UI that does things magically without knowing what you want This is actually just about perfect, as I wanted to integrat...
by powerofrecall
Tue Oct 27, 2015 2:16 pm
Forum: Tools
Topic: Sprite character utility
Replies: 5
Views: 2051

Sprite character utility

Does anyone have/know of a utility that can output VDP characters in the vertically-stripped orientation for sprites? Preferably something like sixpack but for sprites. How do you guys around here do it?
by powerofrecall
Tue Jul 07, 2015 2:34 am
Forum: Exodus
Topic: active disassembly in 2.0.1
Replies: 2
Views: 2150

active disassembly in 2.0.1

To my surprise I got 2.0.1 running in Wine 1.7 on ubuntu (you need to provide the msvc runtime dlls, but it works) but I can't get active disassembly working. The 'Enabled' check-box for data capture keeps unchecking itself. I tested Exodus in a windows 7 virtual machine as well (highly not recommen...
by powerofrecall
Thu Nov 13, 2014 8:30 pm
Forum: Blabla
Topic: GEMS YouTube video
Replies: 91
Views: 23540

Never mind, I never noticed it before. The debug display has multiple pages if you select the menu more than once it seems.
by powerofrecall
Thu Nov 13, 2014 8:25 pm
Forum: Blabla
Topic: GEMS YouTube video
Replies: 91
Views: 23540

What's this? I haven't used it in a few days and when I opened it up I got this. It kind of looks like the debug display, but I haven't seen it before.

Image
by powerofrecall
Fri Oct 31, 2014 3:39 pm
Forum: Blabla
Topic: GEMS YouTube video
Replies: 91
Views: 23540

I'm working on a new tune for the video I'm going to make 8) edit: I'm going to try $_hogthreshold out; I also recompiled retroarch with JACK sound support (low latency) and that helped slightly, but most of the latency is from dosemu it seems. We'll see how that goes, and once I put the video up I'...
by powerofrecall
Wed Oct 29, 2014 2:57 pm
Forum: Blabla
Topic: GEMS YouTube video
Replies: 91
Views: 23540

Unfortunately I don't know how impressive the video will be. There is some latency that doesn't work well for realtime playback of many instruments. Recording seems to be fine, as it was before, so it is receiving all the events--just not fast enough for realtime tempo.
by powerofrecall
Wed Oct 29, 2014 2:23 pm
Forum: Blabla
Topic: GEMS YouTube video
Replies: 91
Views: 23540

Alright, it's working now. I have no idea what I changed, though! I am now starting up gems with 'gems -a 330 -i 5' and it works. This makes zero sense, since I changed dosemu.conf to match the IRQ 7 setting gems wanted, but now that I changed it back to 5, and started with that particular command l...
by powerofrecall
Wed Oct 29, 2014 3:26 am
Forum: Hardware
Topic: Model 1 MD PCB hacks topic
Replies: 17
Views: 8034

Model 1 MD PCB hacks topic

I was thinking about this earlier and thought it really deserved its own topic. I've never seen information about this all contained in one place, and I figured people on this board would have a lot of practical background to contribute so why not. We all know there's a few official board revisions,...
by powerofrecall
Tue Oct 28, 2014 2:27 pm
Forum: Blabla
Topic: GEMS YouTube video
Replies: 91
Views: 23540

I have the IRQ set up correctly. In fact when I was working with GEMS without the emulator before I was using the -i 5 option. First thing I checked. :) I even went back and changed the dosemu.conf file to 5 and tried starting it the way I did before, with -i 5, no luck. So the log does have read() ...
by powerofrecall
Tue Oct 28, 2014 3:08 am
Forum: Blabla
Topic: GEMS YouTube video
Replies: 91
Views: 23540

Alright, I'm stuck on this. I've checked that both my virtual midi port (/dev/snd/midiC1D0) and the symbolic link to that port (~/.dosemu/run/dosemu-midi_in) indeed are receiving MIDI data (doing 'hexdump -C' on both of them provided ongoing data from the MIDI clock as well as other data) but dosemu...
by powerofrecall
Mon Oct 27, 2014 9:12 pm
Forum: Blabla
Topic: GEMS YouTube video
Replies: 91
Views: 23540

4) MIDI connection: I have to setup it everytime, because virmidi devices dissapearing after reboot. I do know that you can fix this by adding the line snd-virmidi to your /etc/modules file and it will persist across reboots. That's not what I'm having trouble with. It's just not working. I did upd...